Jump to content
RWG
Donk

A7753 DOA or am I missing something?

Recommended Posts

Hey all,

I just received my first A7753 rep and it's a beauty - PAM 236. Everything looks great EXCEPT I can't get it to start running. I've been scouring the boards and movement reviews to see if there is something I should know that is different with this movement. I can't imaging what. The QC pics and video looked great. I gave it a few winds of the crow to get it going and then put it on my wrist - it never started.

Giving it some time to release the spring. Could be the cold weather has stuff gummed up? I let it warm considerably but maybe I should wait a little longer.

I'm certainly not trying to roast a dealer and that's why they aren't mentioned. Just curious as to whether anyone else has experienced this. Could be DOA?

Thanks!

Share this post


Link to post
Share on other sites

Well, I answered my own question - sort of. Just got done chatting with the seller and they gave me some tips. The one that worked and got it running - start the chrono. I would have never thought to do that as I thought it might further damage the movement. I guess as a last resort it worked great.

Not sure if this thread will help anyone or not.

Love my new 236!

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...